usenov777
08.02.2021 23:15

Награда 50 !
нужно написать программу в паскаль. попадает ли точка введения пользователем (её координаты) в выделенную область.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ХацуноМико
10.10.2020 22:17

const

  a = 10;

  b = 6;

  R = 8;

var

  x, y : real;

begin

  readln(x, y);

  if // Верхняя заштрихованная область

     (((x>=0) and (x=<a)) and ((y>=0) and (y<=b)) and (sqr(x)+sqr(y)>=sqr(R)))

     or

     // Нижняя заштрихованная область

     ((x<=0) and ((y<=0) and (y>=-b)) and (sqr(x)+sqr(y)<=sqr(R)))

  then writeln('Да')

  else writeln('Нет');

end.

Объяснение:

попробуй вот так, извини если не получилось

0,0(0 оценок)
Ответ:
julianna19
10.10.2020 22:17

PascalABC.NET

begin

 var (x, y) := ReadReal2('Введи координаты точки:');

 if x.InRange(-2, 6) and y.InRange(-2, 6) and

   not ((x * x + y * y <= 2) or

   ((x * x + y * y >= 4) and ((x * x + y * y <= 6) and

   ((x > 0) and (y < 0 then

       Print('Попадает')

 else

   Print('Не попадает')      

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота