aigerka19
26.07.2020 01:12

Написать программу

рассчитать сумму ежемесячных выплат процентов по депозиту, если договор составлен на полгода под 6% годовых или на год под 8% годовых. с клавиатуры ввести сумму вклада и срок договора

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mauntians
06.11.2021 07:28
Import java.util.*; import java.lang.*; import java.io.*; class MyLab { public static void main (String[] args) { int a; //первое число, от которого начнем int b; //второе число, до которого будем считать произведение int product; //произведение всех целых чисел Scanner in; //с этого объекта читаем ввод с клавиатуры in = new Scanner(System.in); System.out.println("Enter A: "); a = in.nextInt(); System.out.println("Enter B: "); b = in.nextInt(); if (a > b) //если число от которого начинаем больше чем до которого нужно считать - поменять их местами { int buf = a; //сохраняем значение a a = b; //присваиваем переменной a значение переменной b b = buf; //присваиваем переменной b значение сохраненной в buf переменной a } product = 1; //инициализируем 1, что бы получить корректное произведение (ни в коем случаи не 0м, если вы не понимаете почему именно 1, то вам нечего делать в программировании, без обид) for (int i = a; i <= b; ++i) //цикл, повторяем на промежутке от a до b с шагом в 1 { product *= i; //умнажаем текущее значение произведения всех целых чисел на текущее целое число } System.out.printf("Product of all integer numbers from A = %d, to B = %d, is = %d\n", a, b, product); } }
0,0(0 оценок)
Ответ:
vikabosch
03.03.2021 11:01

#include <iostream>

#include <string>

using namespace std;

void makeLevel(int n)

{

cout << "*" << endl;

string out ="**";

for(int level=1;level<=n;++level){

  cout << out << endl;

  out.push_back('*');

}

}

void tree(int n)

{

for(int i=1;i<=n;++i){

  makeLevel(i);

}

}

{

cout << "*" << endl;

string out ="**";

for(int level=1;level<=n;++level){

  cout << out << endl;

  out.push_back('*');

}

}

void tree(int n)

{

for(int i=1;i<=n;++i){

  makeLevel(i);

}

}

int main()

{

   int n;

   cin >> n;

   tree(n);

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота