МарвиСК
12.12.2022 16:07

Используя цикл с параметром, написать программу, которая вычисляет сумму заданного с клавиатуры числа элементов ряда 1/2+1/4-1/6+1/

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LENUSEA2007
10.10.2020 09:15

program Calc;

var

 i, n, m: Integer;

 s: Double;

begin

 Write ('Количество членов ряда = ');

 ReadLn (m);

 s := 0.5;

 n := 1;

 for i := 2 to m do begin

   s := s + n / (i * 2);

   n := -n;

 end;

 WriteLn ('S = ', s :20 :20);

 ReadLn;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота