Диана8909
23.03.2020 19:07

Написать программу (паскаль)
в массиве хранится информация о стоимости 1 кг 20 видов конфет. определить, сколько стоят самые дешёвые конфеты . если таких несколько, то должен быть найден индекс первого из них .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Theknopa444
05.08.2020 09:23

program test;

var a:array [1..20] of integer;

min, i, imin: integer;

begin

min:=a[19];

imin:=19;

for i:=1 to 20 do begin

a[i]:=random (151)+150;

write (a[i]:4);

end;

writeln;

for i:=19 downto 1 do begin

if a[i]<min then begin imin:=i; min:=a[i]; end;

end;

write (imin);

writeln;

write (a[imin]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота