idima123
27.01.2020 20:05

Много !
как в паскале написать программу:
вывести первые n степеней числа 2, начиная с нулевой. найти сумму цифр введенного числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
uchikha2016
10.10.2020 11:46

var a,b,c,d:integer;

begin

writeln('введите число'); //запрос числа

readln(a);

d:=a;                 //это для красоты

while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее

 b:=a mod 10;        //берём последнюю цифру числа  

 c:=c+b;             //находим сумму цифр

 a:=a div 10;        //убираем из данного числа последнюю цифру

 end;

 writeln('сумма цифр числа ',d,' = ',c); // вывод результата

end.

Вроде вот)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота