Додоша18
13.01.2021 16:56

Дан массив из 12 целых чисел проверить является ли он по возрастанию. написать программу на с++​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ozzibros
10.10.2020 12:06

Исходник ниже. В задаче говорится, что чисел ровно 12, поэтому сделал статический массив на константное количество элементов. Если предполагается, что программа должна работать и на других размерах массива, то можно сделать динамический массив или использовать контейнер vector.

Объяснение:

#include <iostream>

int main(){

   const int n = 12;

   int a[n];

   for(int i = 0; i < n; i++){

       std::cin >> a[i];

   }

   bool ascending= true;

   for(int i = 1; i < n; i++){

       if (a[i-1] > a[i]){

           ascending = false;

           break;

       }

   }

   if (ascending){

       std::cout << "Yes" << std::endl;

   }

   else{

       std::cout << "No" << std::endl;

   }

   return 0;

}    

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота