Eveliinaa
24.06.2022 18:03

Напишите программу, которая получает число из данного файла, делит его на 3 и записывает ответ в другой файл

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sychewaya8310
10.10.2020 13:33

Программа на языке Pascal. Программа получает число из файла input.txt и записывает результат в файл output.txt

var a: real;

f: text;

begin

assign(f,'input.txt');

reset(f);

read(f,a);

close(f);

assign(f,'output.txt');

rewrite(f);

write(f,a/3);

close(f);

end.

0,0(0 оценок)
Ответ:
kravts222p08eoo
10.10.2020 13:33

PascalABC.NET

begin

 WriteAllText('File2.txt',

   (integer.Parse(ReadAllText('File1.txt')) div 3).ToString)

end.

Объяснение:

Текстовый файл File1.txt содержит запись целого числа.

ReadAllText('File1.txt') считывает сдержимое файла в символьную строку,

integer.Parse( ) выделяет из нее целое целое число, div 3 выполняет деление на 3, результат при преобразуется к строке, на основе которой WriteAllText('File2.txt'( ) создает текстовый файл File2.txt.

Файлы должны находиться в той же папке, что и исходный текст программы, либо надо в именах явно указывать полный путь.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота