KalipsoMirai
18.05.2023 19:22

Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tatyanabelousova
10.10.2020 14:31

На языке Паскаль:

const

  n = 10;  

var

   i, a, max, count: integer;

begin

max = -32768 ;

count := 0;

writeln('МАссив:');

for i := 1 to n do

   begin

   read(a);

 if a > max  

   then  

       begin

       max := a;

       count := 1;

     end;

   else

   if a = max

   then

       inc(count)

   end;

   writeln('Count max = ', count);

end.

0,0(0 оценок)
Ответ:
Маша12345678901111
10.10.2020 14:31

begin

 var a := ArrRandom(10, 1, 9);

 a.Println;

 Println('Кол-во чисел, равных max:',

     a.FindAll(p -> p = a.Max).Count)

end.


Напишите программу определяющую количество максимальных чисел в массиве. массив состоит из 10 чисел
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота