liana200671
20.04.2021 01:12

Написать программу для вычисления значений арифметических выражений:
1) u=a^2*x+e^-x*cos bx/bx-e^-x*sin bx+1
2) f= a^2 in (a+x)-b^3 in(b-x)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alinkachehovska
29.08.2020 18:58
1. Как выше уже сказали, имя файла ОБЫЧНО состоит и правда из двух частей. Это придумали еще давно, сначала просто для удобства, чтобы понимать, что за информация содержится внутри (текст, звук и т. д.) . Впоследствии операционные системы стали использовать расширение для распознавания содержимого и запуска необходимого приложения для обработки файла, или распознавала, что файл является программой и запускается сам (это в Windows и DOS файлы с расширением *.exe, *.bat, *.com) а вот в Линуксе исполняемый файл может иметь любое расширение, или вообще его не иметь. В Windows ( а ранее в DOS) использовалось расширение с ограничениями, в три знака. Сейчас Windows использует и больше знаков для работы (например *.docx). В принципе имя файла может состоять хоть из одной, хоть из десяти частей. Главное его открыть нужной программой, чтобы прочитать.
0,0(0 оценок)
Ответ:
blackmaster2442
13.07.2020 14:02

QPython+SL4A:

import android

import time

import sys, select, os #for loop exit

#Initiate android-module

droid = android.Android()

#notify me

droid.makeToast("fetching GPS data")

print("start gps-sensor...")

droid.startLocating()

while True:

   #exit loop hook

   if sys.stdin in select.select([sys.stdin], [], [], 0)[0]:

       line = input()

       print("exit endless loop...")

       break

   #wait for location-event

   event = droid.eventWaitFor('location',10000).result

   if event['name'] == "location":

       try:

           #try to get gps location data

           timestamp = repr(event['data']['gps']['time'])

           longitude = repr(event['data']['gps']['longitude'])

           latitude = repr(event['data']['gps']['latitude'])

           altitude = repr(event['data']['gps']['altitude'])

           speed = repr(event['data']['gps']['speed'])

           accuracy = repr(event['data']['gps']['accuracy'])

           loctype = "gps"

       except KeyError:

           #if no gps data, get the network location instead (inaccurate)

           timestamp = repr(event['data']['network']['time'])

           longitude = repr(event['data']['network']['longitude'])

           latitude = repr(event['data']['network']['latitude'])

           altitude = repr(event['data']['network']['altitude'])

           speed = repr(event['data']['network']['speed'])

           accuracy = repr(event['data']['network']['accuracy'])

           loctype = "net"

       data = loctype + ";" + timestamp + ";" + longitude + ";" + latitude + ";" + altitude + ";" + speed + ";" + accuracy

   print(data) #logging

   time.sleep(5) #wait for 5 seconds

print("stop gps-sensor...")

droid.stopLocating()

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота