Vikusyadubenko
30.03.2020 14:43

Семь друзей измеряли рост. составьте программу нахождения самого низкого друга. ввод роста создать с генератора случайных чисел в интервале от 150 до 200.
! нужно

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
brody96
17.10.2020 10:41
Вариант 1
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   for i:=1 to length(str) do begin
     if (str[i]='А')or (str[i]='а') then a:=a+1;
     if (str[i]='Б')or (str[i]='б') then B:=b+1;
   end;
   if (A+B)=0 then write('нет таких букв') else write ('A= ',A,' Б= ',b);
end.

вариант 3
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   i:=1;
   while i<=length(str) do begin
    if (str[i]='А')or (str[i]='а') then delete(str,i,1);
    i:=i+1;
    end;
   write(str);
      end.
0,0(0 оценок)
Ответ:
Dildora13
19.04.2021 00:02

Program YouName;

Var i,n:Integer;

s: array[0..75] of Integer; // Объявление массива

Begin

write('Введите количество элементов массива: ');

readln(n); // Ввод кол-ва элементов массива

writeln('');

writeln('Исходный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  // Если используете паскаль ABC, то можно написать так: s[i]:=random(-100,100);

  s[i]:=random(100-(-100)+1)+(-100); // Заполнение элементов массива от -100 до 100.

  write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

 End;

writeln;

writeln('');

writeln('Видоизмененный массив:');

for i:=1 to n do // Перебор от первого до n элементов массива

 Begin

  If (i mod 2 = 0) and (s[i] mod 2 = 0) then // Если элемент и значение массива четное, то..

   Begin

    s[i]:=s[i]*(-1); // Смена знака на противоположный

    write(s[i], '(', i, ')',' '); // Вывод элемента массива с его порядковым номером

   End;

 End;

writeln;

writeln('');

End.

Объяснение: Если есть вопросы, то пишите мне в лс.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота