LuxAeterna
11.04.2021 02:20

Составить программу в паскаль по :
найти среднее арифметическое наибольшего и наименьшего элементов в одномерном массиве ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katya99972011
10.10.2020 17:38

PascalABC.NET

begin

 var n := ReadInteger('n =');

 var a := ArrRandom(n, -99, 99);

 a.Println;

 Println('Результат:', (a.Max + a.Min) / 2)

end.

Turbo Pascal

program abcd;

uses Crt;

const

 nn = 100;

var

 i, n, max, min: integer;

 a: array[1..nn] of integer;

 

begin

 ClrScr;

 Write('n = ');

 Readln(n);

 Randomize;

 max := -32768;

 min := 32767;

 for i := 1 to n do

 begin

   a[i] := Random(199) - 99;

   Write(a[i], ' ');

   if a[i] > max then

     max := a[i]

   else if a[i] < min then

     min := a[i]

 end;

 Writeln;

 Writeln('Результат: ', (max + min) / 2);

 ReadKey

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота