AminaMK
26.09.2022 10:36

1.написать программу вычисления суммы четных элементов массива,состоящего из 10 чисел,заполненных случайным образом от10 до30.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
YourselfRuelfddd
27.01.2020 21:51
Если квадрат натурального числа не превосходит 225, то само это число не может превосходить √225 = 15.
Алгоритм
Заносим в переменную res (результат) число 0. Оно заведомо меньше любого из натуральных чисел в последовательности.
Читаем очередное число в последовательности. Если оно больше res и при этом не превышает 15, записываем его в res. Если оно равно нулю, чтение прекращаем и выводим значение res.

var
  res,num:integer;
begin
  res:=0;
  repeat
    Read(num);
    if (num>res) and (num<=15) then res:=num
  until num=0;
  Writeln(res)
end.
0,0(0 оценок)
Ответ:
mark02062005
22.07.2020 20:02

program z1;

var a:array[1..100,1..100] of integer;

i,j,n,m: integer;

begin

write ('n (n<=100) = ');

readln(n);

writeln;

writeln('Массив: ');

randomize;

for i:=1 to n do

begin

for j:=1 to n do

begin

a[i,j]:=random(10);

write (a[i,j]:3)

end;

writeln;

end;

writeln;

for j:=1 to n do

begin

m:=a[1,j];

for i:=2 to n do

if a[i,j]<m then m:=a[i,j];

writeln('Минимальный элемент ',j,' столбца: ',m)

end

end.

Объяснение:

Вводим количество элементов

Задаём массив и выводим его на экран

Находим минимальный элемент столбца и выводим его на экран

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота