LiksiGalaxy
30.05.2020 07:57

Составить программу,которая читает два числа real а и b,затем вычисляет среднее арифметическое значение и сумму квадратов этих двух чисел.программа должна содержать две процедуры,одна для вычислений,другая для вывода на экран каждого значения.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
wavystrong
06.11.2022 11:38
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
      int n;
      cout<<"n = ";  cin>>n;   // ввод количества элементов массива 
      int a[n];
// заполнение массива и вывод на экран
      for (int i=0;i<n;i++) { 
           a[i]=rand()%15;     cout<<a[i]<<" "; 
      } 
      cout<<endl;  // перевод строки
// сортировка массива по возрастанию
      for (int i=0; i<n-1; i++)
      for (int j=i+1; j<n; j++) 
           if (a[i]>a[j]) swap(a[i],a[j]);
// вывод 4 минимальных
      cout<<"four min numbers:  ";
      for (int i=0; i<4; i++)  cout<<a[i]<<" ";
      cout<<endl;
      system("pause");  // ожидание ввода с клавиатуры
      return 0;
  }
0,0(0 оценок)
Ответ:
pashafil5
06.11.2022 11:38
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
      int n;
      cout<<"n = ";  cin>>n;   // ввод количества элементов массива 
      int a[n];
// заполнение массива и вывод на экран
      for (int i=0;i<n;i++) { 
           a[i]=rand()%15;     cout<<a[i]<<" "; 
      } 
      cout<<endl;  // перевод строки
// сортировка массива по возрастанию
      for (int i=0; i<n-1; i++)
      for (int j=i+1; j<n; j++) 
           if (a[i]>a[j]) swap(a[i],a[j]);
// вывод 4 минимальных
      cout<<"four min numbers:  ";
      for (int i=0; i<4; i++)  cout<<a[i]<<" ";
      cout<<endl;
      system("pause");  // ожидание ввода с клавиатуры
      return 0;
  }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота