Чевапчичи
01.05.2020 00:38

Составить программу для вычисления суммы и среднего арифметического значения всех элементов заданного одномерного массива а, состоящего из 10-ти элементов. на языке с#

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mileshka890
18.12.2021 04:49

var j, a, b, n: integer;

label 1;

begin

1: randomize;

  a: = random (9);

  b: = random (9);

  write (a, '*', b, '=');

  read (n);

  if n = (a * b) then writeln ('відповідь вірний! ')

            else writeln ('відповідь неправильний! ');

  writeln ('продовжуватимеш? ');

  writeln ('якщо так то натисни 1');

  writeln ('якщо немає то натисни 2');

  read (j);

  if j = 1 then goto 1;

  if j = 2 then writeln ('до побачення! ');

end.

начебто так, точно не пам'ятаю.

0,0(0 оценок)
Ответ:
VeshkinRuslan
15.06.2020 05:12
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  var c:=s.ToWords.Where(t->t.Length>1).SelectMany(w->w.Pairwise)
      .Select(t->t[0]+t[1]).GroupBy(t->t).Select(t->(t.Key,t.Count))
      .OrderByDescending(t->t[1]).ThenByDescending(t->t[0]).First[0];
  Writeln('Чаще других встречается цепочка "',c,'"')
end.

Пример
TWAS BRILLIG AND THE SLITHY TOVES DID GYRE AND GIMBLE IN THE WABE ALL MIMSY WERE THE BOROGOVES AND THE MOME RATHS OUTGRABE
Чаще других встречается цепочка "TH"

Замечание: ограничение на длину строки увеличено до 2 млн. символов.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота