233423
20.02.2022 19:34

Найти сумму положительных байтов массива, заключенных между а и в. предусмотреть сообщение о возникшем переполнении.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Зефирка170504
15.08.2021 17:57
Формула нахождения размера файла - I=t*b*f*k,где t - это время в секундах,b - глубина кодирования ,f - частота дискретизации,k - количество каналов.Перейдём к задаче =>  2 минуты - 120 секунд,
8кГц - 8 000 отсчётов в секунду - представим как 2^3*2^10;16 = 2^4,
Нужно помнить ,что  1 Мбайт = 2^20 байт = 2^23 бит,                                    1 Кбайт = 2^10 байт = 2^13 бит 
т.к нам надо ответь дать в мегабайтах.Делим всё на 2^23
120 представим как 60*2

I=1*2^3*2^10*2^4*120/2^23=2^17*2*60/2^23=2^18*60/2^23=> степени сокращаем получаем 60/2^5 =>60/32 = примерно 1,875 => округляем до целых  будет 2 .ответ 2 мегабайта.
0,0(0 оценок)
Ответ:
скмниниручвк
11.05.2023 08:07
Program aaa;
var
  s, b, l, c: real;
begin
  writeln('введите s, b, l');
  readln(s, b, l);
  c := b / 100 * s * 2 * l;
  writeln('стоимость поездки: ', c)
end.

program aaa;
{Написать программу пересчета веса из фунтов (f) в килограммы (kg)
(1 фунт равен 409,5 г).} 
var
  f,kg: real;
begin
  writeln('введите f');
  readln(f);
  kg:=f*409.5/1000;
  writeln(f,' фунтов = ', kg:8:3,' килограмм')
end.

program aaa;
{Написать программу Конвертер величин: 
с клавиатуры вводиться вес информации в байтах (b). 
На выходе получаем перевод величины в: биты (bi) , килобайты (kb),
Мегабайты (mb), гигабайты (gb).
1байт = 8 бит
1Кб (килобайт) = 1024 байт
1Мб (мегабайт) = 1024 Кб
1Гб (гигабайт) = 1024 Мб
1Тб (терабайт) = 1024 Гб} 
var
  b,bi,kb: real; mb,gb,tb: decimal;
begin
  writeln('введите b');
  readln(b);
  bi:=b*8;
  kb:=b/1024;
  mb:=kb/1024;
  gb:=mb/1024;
  tb:=gb/1024;
  writeln(b,' байт = ', bi,' бит');
  writeln(b,' байт = ', kb,' килобайт');
  writeln(b,' байт = ', mb,' мегабайт');
  writeln(b,' байт = ', gb,' гигабайт');
  writeln(b,' байт = ', tb,' терабайт')
end.
//формат вывода (к-во знаков ...) определите сами
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота