tylkerwest
16.03.2023 07:53

Составить программу в паскале. найти сумму значений функции у=x2 - 5x+6 на [0; 3], для целых значений аргумента.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ladybutiyarowa
17.08.2020 15:12

{$CODEPAGE UTF8}

program QuadraticEquation;

var

a, b, c, x1, x2, discriminant : real;

begin

{ввыод данных}

write('a = ');

readln(a);

write('b = ');

readln(b);

write('c = ');

readln(c);

{дискриминант}

discriminant := sqr(b) - 4 * a * c;

if discriminant < 0 then

writeln('Квадратное уравнение не имеет корней')

else

begin

if discriminant = 0 then

begin

{квадратное уравнение имеет два одинаковых корня}

x1 := -b / (2 * a);

x2 := x1;

end

else

begin

{уравнение имеет два разных корня}

x1 := (-b + sqrt(discriminant)) / (2 * a);

x2 := (-b - sqrt(discriminant)) / (2 * a);

end;

{вывод корней уравнения}

writeln('x1 = ', x1:8:3);

writeln('x2 = ', x2:8:3);

end;

writeln('Press Enter to Exit...');

readln;

end.

Объяснение:

Программа для решения квадратного уравнения на языке программирования Паскаль

В (Lazarus)(не реклама) Лутьше попробуй это вбить .Те создаст калькулятор и ты сможешь посчитать.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота