ladygum78
27.09.2022 21:47

Напишите программу: подсчитать количество нулей в массиве, состоящем из n целых чисел. элементы массива задавать вручную.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Среднячёк
11.08.2020 21:54

1. Динамический массив

program p_1;

var n,i,k:integer;

a:array of integer;

begin

write('Введите количество элементов массива ');

readln (n);

a := new integer[n+1];

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

2. Статический массив

program p_1;

var n,i,k:integer;

a:array [1..1000] of integer;

begin

write('Введите количество элементов массива ');

readln (n);

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота