зика356
05.02.2023 07:41

Напишите программу , которая в последовательности определяет количество и сумму четных чисел. программа получает на вход целые числа , количество введённых чисел не известно, последовательность чисел заканчивается 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kreatuv41kp06t42
08.05.2022 20:01

//PascalABC.Net 3.1 сборка 1200

var

   number: integer;

   sum, sum_all, k: integer;

begin

   repeat

       write('Элемент последовательности => ');

       readln(number);

       

       if (number mod 10 = 2 ) and (number mod 4 = 0) then sum := sum + number;

       if (number <= 100) then k := k + 1;

       sum_all := sum_all + number;

   until number = 0;

   

   writeln('Сумма всех чисел, которые кратны 4 и заканчиваются на цифру 2 = ', sum);

   writeln('Сумма всех = ', sum_all);

   writeln('Кол-во чисел, которые не больше 100 = ', k);

end.

0,0(0 оценок)
Ответ:
uliana3447
08.05.2022 20:01

//PascalABC.Net 3.1 сборка 1200

var

   number: integer;

   sum, sum_all, k: integer;

begin

   repeat

       write('Элемент последовательности => ');

       readln(number);

       

       if (number mod 10 = 2 ) and (number mod 4 = 0) then sum := sum + number;

       if (number <= 100) then k := k + 1;

       sum_all := sum_all + number;

   until number = 0;

   

   writeln('Сумма всех чисел, которые кратны 4 и заканчиваются на цифру 2 = ', sum);

   writeln('Сумма всех = ', sum_all);

   writeln('Кол-во чисел, которые не больше 100 = ', k);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота