Svetafun46
03.02.2020 01:46

Написать программу на с++

вычислить значение натурального логарифма с точностью до
ε=10-^7 через суммы трех рядов:

(картинка в перекрепленном)

для вычисления слагаемых необходимо использовать рекуррентные соотношения. сравнивать результат, полученный после вычисления всех трех рядов в точках x=1, x=1.2, x=1.5, x=1.8, x=2. сравнивать полученные результаты со значениями натурального логарифма в указанных точках x.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
M1A1T1E1M1AT1I1K
15.05.2020 21:16

1

var

mas:array[1..100] of integer;

i,n:integer;

en,out:text;

res:real;

qw,qwe:string;  

begin

 n:=0;

 i:=1;

 write('Введите полный путь к импортируемому файлу: ');readln(qw);

 write('Введите полный путь к экспортируемому файлу: ');readln(qwe);

 assign(en,qw+'.txt'); assign(out,qwe+'.txt');  

 reset(en); rewrite(out);

 while not Eof(en) do    

 begin

 readln(en,mas[i]);      

 n:=n+mas[i];                

 inc(i);        

 end;

   res:=(n/(i-1));  

   write(out,res);  

   close(out);      

   close(en);

 end.

Там во вторую тупо добавляешь:

 max:=-100001;

 min:=100001;

if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];

 if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];  

if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')

 else  

 begin

   writeln(out,min);

   writeln(out,max);  

Тоже такие же задачи решал)) лол). Ты не из 604??)))

0,0(0 оценок)
Ответ:
Крейми51
09.04.2022 08:39

1)Микротра́вма (греч. mikros малый + trauma рана, повреждение) повреждение, возникающее в результате воздействия небольших по интенсивности усилий и приводящее к нарушению функции и микроструктуры тканей.

2)Сидячее положение в течение длительного времени. Казалось бы, за компьютером человек сидит в расслабленной позе, однако она является для организма вынужденной и неприятной: напряжены шея, мышцы головы, руки и плечи, отсюда остеохондроз, а у детей - сколиоз.

3)Повторяющиеся действия приводят к накоплению продуктов распада в мышцах. Эти продукты и вызывают болезненные ощущения. Очень трудно предотвратить повторяющиеся движения кистей и ладоней при работе на компьютере, однако регулярные перерывы и упражнения на растягивание мышц могут предотвратить ПВПН и ПТВРК.

4)- повышенная запыленность и загазованность воздуха рабочей зоны;

- повышенная или пониженная температура поверхностей оборудования, мате­риалов;

- повышенная или пониженная температура воздуха рабочей зоны;

- повышенный уровень шума на рабочем месте;

- повышенный уровень вибрации;

- повышенный уровень инфразвуковых колебаний;

- повышенный уровень ультразвука;

- повышенное или пониженное барометрическое давление в рабочей зоне и его резкое изменение;

- повышенная или пониженная влажность воздуха;

- повышенная или пониженная подвижность воздуха;

- повышенная или пониженная ионизация воздуха;

- повышенный уровень статического электричества;

- повышенный уровень электромагнитных излучений;

- повышенная напряженность электрического поля;

- повышенная напряженность магнитного поля;

- отсутствие или недостаток естественного света;

- недостаточная освещенность рабочей зоны;

- повышенная яркость света;

- пониженная контрастность;

- прямая и отраженная блесткость;

- повышенная пульсация светового потока;

- повышенный уровень ультрафиолетовой радиации;

- повышенный уровень инфракрасной радиации;

- острые кромки, заусенцы и шероховатость на поверхностях заготовок, инстру­ментов и оборудования;

- расположение рабочего места на значительной высоте относительно поверх­ности земли (пола);

8)"Египтянин"

"Глядя в небо"

"Абра-кадабра"

9)"Разговор с ладонью"

"Приподнимание крышки стола"

11)До на­ча­ла ра­бо­ты: про­ве­рить ис­прав­ность элек­тро­про­вод­ки, ро­зе­ток и вилок ком­пью­те­ра, за­зем­ле­ние ПК.

Во время ра­бо­ты:

необ­хо­ди­мо ак­ку­рат­но об­ра­щать­ся с про­во­да­ми;

за­пре­ща­ет­ся ра­бо­тать с неис­прав­ным ком­пью­те­ром;

нель­зя за­ни­мать­ся очист­кой ком­пью­те­ра, когда он на­хо­дит­ся под на­пря­же­ни­ем;

недо­пу­сти­мо са­мо­сто­я­тель­но про­во­дить ре­монт обо­ру­до­ва­ния при от­сут­ствии спе­ци­аль­ных на­вы­ков;

нель­зя рас­по­ла­гать рядом с ком­пью­те­ром жид­ко­сти, а также ра­бо­тать с мок­ры­ми ру­ка­ми;

нель­зя в про­цес­се ра­бо­ты с ПК при­ка­сать­ся к дру­гим ме­тал­ли­че­ским кон­струк­ци­ям (на­при­мер, ба­та­ре­ям);

не до­пус­ка­ет­ся ку­ре­ние и упо­треб­ле­ние пищи в непо­сред­ствен­ной бли­зо­сти с ПК и др.

4. По окон­ча­нии ра­бо­ты:

вы­клю­чить ком­пью­тер;

же­ла­тель­но про­ве­сти влаж­ную убор­ку ра­бо­че­го места;

от­клю­чить элек­тро­пи­та­ние.

12) характеристика рабочего места; общие требования к организации рабочего места;оснащение рабочего места;пространственная организация рабочего места и порядок размещения организационной оснастки, инструментов, материалов;описание организации труда на рабочем месте и рекомендуемые передовые приемы и методы труда;организация обслуживания рабочего места и средства связи со службами обслуживания и управления;условия труда на рабочем месте; требования безопасности и охраны труда; нормирование труда, применяемые формы и системы оплаты труда;документация на рабочем месте;экономическая эффективность от внедрения типового проекта.

13)Электрический ток представляет собой скрытый тип опасности, т.к. его трудно определить в токо - и нетоковедущих частях оборудования, которые являются хорошими проводниками электричества. Смертельно опасным для жизни человека считают ток, величина которого превышает 0,05А.. С целью предупреждения поражений электрическим током к работе должны допускаться только лица, хорошо изучившие основные правила по технике безопасности.

14)Зануление отличается от заземления тем, что оно рассчитано на эффект короткого замыкания. Если распределение нагрузок на производстве является более или менее равномерным, и нулевой проводник в основном выполняет защитные функции, то в таком случае «ноль» цепляется к корпусу электрического мотора. Короткое замыкание происходит при попадании напряжения одной из фаз на корпус электрического двигателя.

21)Дымовые пожарные извещатели

Тепловые пожарные извещатели

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота