На си написать.
напишите программу вывода из файла первую и последнюю строки.
с объяснением )
и объясните как выводить любую строку.
с наступающим

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
HunterX05
10.10.2020 23:18

#include "stdio.h"

//Указатель на файл

FILE * pFile;

//Размер файла

int size;

//Буффер

char  buffer[160];

//Число считанных байт

size_t result;

if(pFile)

{

//Получаем размер файла

fseek (pFile, 0, SEEK_END);   // non-portable

size=ftell (pFile);

//Читаем первые 80 символов

fseek (pFile, 0, SEEK_SET);   // non-portable

result = fread (buffer,1,80,pFile);

 //Читаем вторые 80 символов

fseek (pFile, (size-80), SEEK_SET);   // non-portable

result = fread (&buffer[80],1,80,pFile);

 //Выводим результат

printf ("String",buffer,80);

fclose ( pFile);

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота