Flarissa163
19.05.2023 12:12

Решить на языке программирования golang(или просто go) : (нужно написать программу)
последовательность состоит из натуральных чисел и завершается числом 0. определите количество элементов этой последовательности, которые равны ее наибольшему элементу.

формат входных данных

вводится непустая последовательность натуральных чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания).

формат выходных данных

выведите ответ на .
пример данных:
1
3
3
1
0
получается 2 (т.к. у нас два наибольших элемента .(две тройки) )
или хотя бы поправьте моё решение(у меня почему-то выдает 1 вместо 2) :
package main
import "fmt"
func main() {
var a,n,i,maxi int
maxi=0
n=0
for i! =0{
if a> maxi {
maxi=a
n=1
} else if a==maxi {
n+=1
}
fmt.scan(& a)
}
fmt.println(n)
}

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mityatimofeev
31.03.2020 22:35

Объяснение:

#include <iostream>

using namespace std;

int main()

{

   int N, counter = 1, max_counter=1,post;

   cin >> N;//всего матчей

   cin >> post;// ввод первого числа последовательности  

   for (int i = 0; i < N-1; i++) {

       int a;

       cin >> a;// ввод остальных N-1 чисел последовательности

       if (a == post && a == 1) {

           counter++;

           if (counter > max_counter)

               max_counter = counter;

       }

       else

       {  

           counter = 1;

       }

       post = a;

   }

       cout << max_counter;

   return 0;

}

0,0(0 оценок)
Ответ:
пир14
19.03.2020 03:54

Как и в математике. Сначала выполняем операции в скобках, потом вне.

a=10 b=20

a) rez:= (a=10) or (b>10) = TRUE or TRUE = TRUE

б) rez:= (a>5) and (b>5) = TRUE and TRUE = TRUE

в) rez:= (not (a<15)) or (b>20) = (not TRUE) or FALSE = FALSE or FALSE = FALSE

Программа, так полагаю, на паскале. Вот примерный код

var

a, b :integer;

rez : boolean;

begin

a:=10;

b:=20;

rez:=(a=10) or (b>10);

writeln(rez);

end.

Вместо строчки rez:=(a=10) or (b>10); подставляешь то, что тебе нужно, и будет счастье.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота