Messi111111111111111
07.08.2021 20:41

составьте программу для вывода наименовании месяца года в зависимости от его числового выражения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ИрБи562
05.04.2020 09:56

from builtins import print

a = int(input())

b = int(input())

c = int(input())

d = int(input())

if (a + b + c + d) == (a * b * c * d):

  print('Сумма и произведения равны')

else:

  if (a + b + c + d) < (a * b * c * d):

      print('Cумма меньше произведения')

  else:

      print('Сумма больше произведения')

#2

sum = 0

for i in range(4):

  a = int(input())

  if a > 0:

      sum+=a

print(sum)

# 3

sum = 0

for i in range(4):

  a = int(input())

  if a < 0:

      sum += a

print(sum)

# 4

minus = 0

plus = 0

null = 0

for i in range(4):

  a = int(input())

  if a < 0:

      minus += 1

  else:

      if a > 0:

          plus += 1

      else:

          null += 1

print('Положительных {}, отрицательных {}, нулей {}'.format(plus, minus, null))

# 5

a = int(input())

b = int(input())

polusum = (a * b) / 2

ydvoen = 2 * a * b

if a > b:

  a = polusum

  b = ydvoen

else:

  b = polusum

  a = ydvoen

print(a, b)

# 6

z = []

for i in range(3):

  z.append(input())

if z[0] == min(z):

  z[0] = 0

else:

  if z[1] == min(z):

      z[1] = 0

  else:

      z[2] = 0

print(z)

#7

z = []

for i in range(4):

  z.append(int(input()))

print(max(z)-min(z))

# 8

M = 0

kvartal = 0

M = int(input())

if (M > 1) and (M < 4):

  kvartal = 1

  print('Квартал - ', kvartal)

else:

  if (M > 3) and (M < 7):

      kvartal = 2

      print('Квартал - ', kvartal)

  else:

      if (M > 6) and (M < 10):

          kvartal = 3

          print('Квартал - ', kvartal)

      else:

          if (M > 9) and (M < 13):

              kvartal = 4

              print('Квартал - ', kvartal)

if kvartal == 0:

  print('Введён неккоректный месяц')

# 9

list = ['крыса', 'корова', 'тигр', 'заяц', 'дракон', 'змея', 'лошадь', 'овца', 'обезьяна', 'петух', 'собака', 'свинья']

god = int(input())

opred = (god - 1995) % 12 - 1

print(list[opred])

Объяснение:

0,0(0 оценок)
Ответ:
Tittans101
04.06.2022 18:42

Логические элементы — устройства, предназначенные для обработки информации в цифровой форме (последовательности сигналов высокого — «1» и низкого — «0» уровней в двоичной логике, последовательность «0», «1» и «2» в троичной логике, последовательностями «0», «1», «2», «3», «4», «5», «6», «7», «8» и «9» в десятичной логике). Физически логические элементы могут быть выполнены механическими, электромеханическими (на электромагнитных реле), электронными (в частности, на диодах или транзисторах), пневматическими, гидравлическими, оптическими и другими.


информатика от 1. Постройте схемы, работа которых описывается логическими формулами: 2. В предложен
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота