dianafaizullin1
13.02.2021 00:27

Составьте программу на деление, используя статические и динамические типы данных.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Макс917572
21.09.2020 01:00

Текстовый редактор Microsoft Word предназначен для набора текста с клавиатуры, а также редактирования, копирования, создания таблиц, одним словом для того, чтобы созданный Вами документ выглядел максимально привлекательно, стильно и информативно. С вы можете составить такие документы как:

оформить курсовую или дипломную работу;

составить резюме кандидата на должность;

напечатать заявление о приеме на работу;

подготовить многомиллионный договор на поставку товара;

сочинить и отредактировать для печати целый роман.

Другими словами, текстовый редактор Microsoft Word, будет полезен абсолютно любому пользователю компьютера, который так или иначе связан с текстовыми документами.

0,0(0 оценок)
Ответ:
Алая5кровь
09.10.2020 23:13
//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота