Xylinado
18.10.2021 11:33

Напишите программу, которая заполняет массив из n = 8 элементов случайными числами в диапазоне [0,10], выводит его на экран, а затем выводит на экран квадраты всех элементов массива.
с++
использовать библиотеки #include
#include

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Котя534
11.10.2020 03:18

Код можно сократить вплоть до одного for, объединив все в одно. На будущее: #include - это не библиотека, это директива

Объяснение:

#include <iostream>

#include <random>

#include <time.h>

using namespace std;

int main() {

int mas[8];

srand(time(NULL));

for (int i = 0; i <= 7; i++) mas[i] = rand() % 11;

for (int i = 0; i <= 7; i++) mas[i] *= mas[i];

for (int i = 0; i <= 7; i++) cout << mas[i] << " ";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота