yanakuzmina1
12.02.2020 01:55

PYTHON 3
Напишите программу, которая будет вложенных циклов выводить на экран следующею фигуру. Также длина самой длинной строчки со звёздочками должна равняться N.
Вводные данные: на первой строке число N.
Исходные данные: фигура со звездочками, где длинная строка содержит N звездочек.
Примечание: команда print() может быть использована с параметром "end=", что означает по окончанию вывода данного объекта продолжить со следующим значением. Написав print("*", end = " ") можно сделать чтобы звёздочки выводились через пробел, а затем написав print(end="\n"), чтобы осуществить перенос.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
muhkirill2017
11.10.2020 11:31

n = int(input())

for i in range(n):

   for j in range(i):

       print("*",end = " ")

   print('*')

for i in range(n-2,-1,-1):

   for j in range(i):

       print("*",end = " ")

   print('*')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота