Den3801
27.02.2022 18:39

1. Напишите программу, которая вводит из файла весовую матрицу графа и определяет длины всех оптимальных маршрутов с алгоритма Флойда-Уоршелла.

Оцените асимптотическую сложность алгоритма Флойда-Уоршелла.

ответ:

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Satana04
14.05.2023 20:01
1) #include <iostream>
using namespace std;

unsigned long fact(int x)
{
unsigned long f=1;
for (int i=1; i<=x; i++)
{
f*=i;
}
return f;
}

int main()
{
for(int i=0; i<=50; i++)
cout <<i <<"!=" <<fact(i) <<endl;
return 0;
}

2)
#include <iostream>
using namespace std;

int main()
{
int max=0;
int n;
do {
cin >>n;
if (n!=0 && n>max) max=n;
} while (n!=0);

cout <<"\nMAX=" <<max <<endl;
return 0;
}
0,0(0 оценок)
Ответ:
Двоищник234
04.01.2020 12:07
Var err, right, answer : integer;
BEGIN
err := 0; right := 0;
writeLn('Сейчас Вам будет предложен тест по сериалу "Кухня". ');
writeLn('К каждому вопросу два варианта ответа. ');
writeLn('Вы должны ввести номер правильного ответа и нажать <Еnter>');
writeLn;
writeLn('Понравилась последняя серия Кухни?: ');
writeLn('1. Да');
writeLn('2. Очеень понравилась');
Write('Ваш ответ: ');ReadLn(answer);
if answer = 1 then begin
WriteLn('Неправильно');
err := err + 1;
end
else begin
WriteLn('Правильно');
right:=right+1;
end;
writeLn;
writeLn('Жена Макса: ');
writeLn('1. Вика');
writeLn('2. Катя');
Write('Ваш ответ: ');ReadLn(answer);
if answer = 1 then begin
WriteLn('Правильно');
right := right +1;
end
else begin
WriteLn('Неправильно');
err := err + 1;
end;
writeLn;
writeLn('Любишь этот сериал?: ');
writeLn('1. Обожаю');
writeLn('2. Очееень :3');
Write('Ваш ответ: ');ReadLn(answer);
if answer = 2 then begin
WriteLn('Правильно');
right := right +1;
end
else begin
WriteLn('Неправильно');
err := err + 1;
end;
WriteLn('Правильных ответов: ', right);
WriteLn('Неправильных ответов: ', err);
END.
Я сделяль :3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота