planeta88
06.06.2022 08:06

Составьте программу,проверяющую верно ли утверждение,что сумма введённого вами числа делится на 5.(Не используя Паскаль и прочие языки программирования)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alexbarbos75
15.05.2023 08:36
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write('Введите количество строк и столбцов массива: ');
  var (m,n):=ReadInteger2;
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-5,5);
  a.Println(3); Writeln(3*a.ColCount*'-');
  var k:=ReadInteger('Введите число А для замены нулей:');
  a.Transform(x->x=0?k:x);    // вот это и вся замена...
  Writeln('*** Результат ***');
  a.Println(3)
end.

Пример
Введите количество строк и столбцов массива: 7 10
*** Исходный массив ***
  2 -4 -1  3 -4 -4  2  1 -5 -1
 -5  2 -3 -1 -1 -5  2 -4 -5 -5
 -4  1  0 -1  5 -1  1  4  3 -4
  2  3  3  1 -3  3 -4  0 -3  3
 -3 -1  4 -3 -1 -5 -1  1  2  2
 -2  4 -2  3  3 -5  1  5  4  3
  1  3  4  5  3 -2  5  2 -4  1

Введите число А для замены нулей: 77
*** Результат ***
  2 -4 -1  3 -4 -4  2  1 -5 -1
 -5  2 -3 -1 -1 -5  2 -4 -5 -5
 -4  1 77 -1  5 -1  1  4  3 -4
  2  3  3  1 -3  3 -4 77 -3  3
 -3 -1  4 -3 -1 -5 -1  1  2  2
 -2  4 -2  3  3 -5  1  5  4  3
  1  3  4  5  3 -2  5  2 -4  1
0,0(0 оценок)
Ответ:
ledzep
22.05.2023 20:50
{Массив задаётся с генератора случайных чисел. после того как он задан, последовательно перебираются все элементы и определяется наименьший элемент.}
procedure minZNmas;
 var
  mas: array[1..15] of integer;
  k: integer;
  min: integer;  s: string;
begin

  randomize; 
//Заполнение массива случайными величинами 
  s:=''; 
  for k:=1 to 15 do begin   
     mas[k]:=random(800);   
     s:=s+IntToStr(mas[k])+','; 
  end;

  //Поиск минимального значения 
     min:=mas[k]; 
     for k:=1 to 15 do   
        if mas[k]<min then
           min:=mas[k];

      Application.MessageBox(PChar(s),'Значения массива', MB_ICONINFORMATION);

Application.MessageBox(PChar(IntToStr(min)),'Минимальное значение', MB_ICONINFORMATION);

end;

begin   minZNmasend.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота