eevelinka742
09.06.2023 01:04

В рамках национальной программы «Цифровая экономика» знающими людьми было принято решение о построении Национальной Вычислительной Машины (сокращённо НВМ). Работать эта машина будет под управлением Национальной Операционной Системы и будет использоваться исключительно в национальных интересах.

Ивану Петровичу, сыну Петра Ивановича, программисту 4-го разряда, поручили реализовать часть базового функционала Машины, в рамках которого машина должна научиться вычислять, сколько раз число N, состоящее только из нулей и единиц, без ведущих нулей, можно делить на двойку до тех пор, пока результат остаётся чётным.

Формат ввода
Вводится чётное положительное число N, состоящее из десятичных цифр 0 и 1, без ведущих нулей.

Формат вывода
Единственное целое число — ответ на задачу.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mmb1
24.07.2021 06:05

#include <iostream>

#include <cmath>

#include <algorithm>

#include <vector>

using namespace std;

int absSum(vector<int> &k){

   int sum = 0;

   for(auto &i: k) sum += abs(i);

   return sum;

}

void solve(){

   int n, m;

   cin >> n >> m;

   vector<vector<int>> a(n, vector<int> (m));

   for(vector<int> &i: a)

       for(int &j: i)

           cin >> j;

   pair<int, int> ans = {absSum(a[0]), 0};

   for(int i = 1; i < n; i++){

       int curSum = absSum(a[i]);

       if(curSum > ans.first) ans = {curSum, i};

   }

   cout << "Line #" << (ans.second + 1) << " has the biggest absolute sum: " << ans.first;

}

signed main() {

   solve();

}

0,0(0 оценок)
Ответ:
Виола122006
18.01.2022 19:33

#include <stdio.h>

#include <windows.h>

#define _MAX_STRING_SIZE_ 100

int main()

{  

   SetConsoleOutputCP(65001);

   char str[_MAX_STRING_SIZE_];

   scanf("%[^\n]%*c", str);// читает строку с пробелами

   int counter = 0;

   for(int letter = -96; letter <= -17; letter++)// проверка первого слова // а = -96,  я = -17

       if(str[0] == letter)

           counter++;

   for(int i = 0; i < _MAX_STRING_SIZE_ - 1; i++)

       if(str[i] == ' ')

           for(int letter = -96; letter <= -17; letter++) // а = -96,  я = -17

               if((int)str[i + 1] == letter)

                   counter++;

   printf("%d", counter);

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота