deadloxSasha
27.03.2021 03:35

Напишите программы в Pascal.
1. Напишите программу, которая определяет число учеников в классе, чей вес
превышает средний.
2. Напишите программу вычисления расстояния между точками А и В, если известны
координаты xA, yA, xB, yB.
3. Напишите программу нахождения всех двухзначных чисел и вычисления их
суммы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Виолетик2004
12.08.2022 13:52

using System;

namespace kp9p_pr_10_zad_7

{

   class Program

   {

       delegate void Anon(int a, int b, int h); // анонимный метод  

       delegate double Lymbd(int a, int h); // метод с использованием лямбда выражения  

       static void Main(string[] args)

       {

           bool usl = false;  

           int a = 0, b = 0, h;  

           while (usl != true)

           {

               Console.Write("Введите первое значение: ");

               a = Convert.ToInt32(Console.ReadLine()); // ввод первого значения  

               Console.Write("Введите второе значение: ");

               b = Convert.ToInt32(Console.ReadLine()); // ввод второго значения  

               if (a < b) // если a меньше b  

               {

                   usl = true; // условие = правда  

               }

               else

               {

                   Console.WriteLine("\nНекорректный ввод\n");  

               }

           }

           Console.Write("Введите шаг: ");

           h = Convert.ToInt32(Console.ReadLine()); // ввод шага  

           void anon(int a1, int b1, int h1)

           {

               Console.WriteLine("\nС использованием анонимного метода\n\nЗначение аргумента:\tответ:\n"); // /t - табуляция  

               for (int i = a; i <= b; i += h1)

               {

                   Console.WriteLine("{0}\t\t\t{1:f2}", i, Math.Sqrt(h1) * Math.Pow(Math.Cos(i), 2)); // вычисление и вывод значений функции  

               }

           }

           anon(a, b, h);

           static double lyamb(int a1, int h1) => Math.Sqrt(h1) * Math.Pow(Math.Cos(a1), 2); // вычисление значений функции  

           Console.WriteLine("\nС использованием лямбда-выражения\n\nЗначение аргумента:\tответ:\n");  

           for (int i = a; i <= b; i += h)

           {

               Console.WriteLine("{0}\t\t\t{1:f2}", i, lyamb(i, h)); // вывод значений функции  

           }  

       }

   }

}

0,0(0 оценок)
Ответ:
46hitman46
12.08.2022 13:52
Program Table;
uses math; //подключаем математический модуль, возможно с модулем я ошибся
var  // объявляем локальные переменные для программы
    a , b, h : Real; //указывает дробный тип числа

function calculate_f( x: Real) : Real; //объявляем функцию в теле программы
begin
    calculate_f := 1/2*sin(x/4+1) ;   //записываем результат вычисления в функцию
end;

Begin
    a := -0.99; //определяем
    b :=  50.0;  //вводные
    h := 0.1; //значения

    while a < b do begin //пока "a" меньше "b"
        writeln("F(", a, ') = ', calculate_f(a)); //выводим результат вычислений в строку
        a := a + h; //прибавляем шаг "h"
    end;
end.

Я могу и ошибиться, потому что писал на Паскале оочень давно :D
Поэтому Вам прийдется поправить некоторые ошибки в коде.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота