машаоляапро
11.02.2022 18:23

Напишите программу для счета мелких денег.
Она должна спрашивать:
«Сколько у вас монет по 50 копеек?»;
«Сколько у вас монет по 10 копеек?»;
«Сколько у вас монет по 5 копеек?»;
«Сколько у вас монет по 1 копейке?».
После этого на экране должна появиться общая сумма.

Пример входа:
Сколько у вас монет по 50 копеек? 10
Сколько у вас монет по 10 копеек? 10
Сколько у вас монет по 5 копеек? 10
Сколько у вас монет по 1 копеек? 10

Пример результата:
Всего у вас 660 копеек.

НА ПИТОНЕ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Valeriya2576
15.03.2020 23:30

program p1;

uses crt;

var a,b,c,d,e,s:integer;

begin

a:=50;

b:=10;

c:=5;

d:=1;

writeln('сколько у вас монет по 50');

read(e);

s:=a *e;

writeln('сколько у вас монет по 10');

read(e);

s:=s+b*e;

writeln('сколько у вас монет по 5');

read(e);

s:=s+c*e;

writeln('сколько у вас монет по 1');

read(e);

s:=s+d*e;

write('Всего копеек ',s);

end.

Подробнее - на -

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота