danillbiz
06.09.2022 17:27

Создать проинициализированный массив из предложения "Век живи - век учись."
Pascal или VB.net

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
art1610
12.02.2023 04:16
Сначала немного теории.
Тут у нас импликация(если..то...), комбинированная с конъюнкцией(и).
Таблица истинности импликации(стрелочки):
0 0 1
0 1 1
1 0 0
1 1 1
Общее правило: если a<=b, тогда правда
Таблица истинности конъюнкции(/\):
0 0 0
0 1 0
1 0 0
1 1 1
Общее правило: если есть одна ложь-всё ложь.
Про НЕ и гуманитарий поймёт.
Про данный пример:
Нам нужен вариант, где оба выражения являются правдой, т.к. между ними стоит И
Подробно рассмотрим первый вариант:
Ирина
Первая буква гласная-правда
Вторая буква гласная-ложь
Значит, результат импликации-ложь, в чём можно убедиться взглянув на таблицу истинности, но, так как НЕ так же присутствует в данном условии, это выражение возвращает правду.
Последняя буква гласная-правда
Так как оба выражения при конъюнкции правда, всё выражение является правдой и удовлетворяет условию.
0,0(0 оценок)
Ответ:
bIshkin
09.11.2020 15:27

#include <iostream>

using namespace std;

int main()

{

   int length, kilometer;

   cout << "Введите расстояние (в метрах): ";

   cin >> length;

   if (length < 1000) {

       cout << "0 км. " << length << " м.";

   }

   else {

       kilometer = length / 1000;

       length = length % 1000;

       cout << kilometer << " км. " << length << " м.";

   }

}

Объяснение:

Вариант 23. Написать программу, которая переводит расстояние, указанное в метрах, в километры и метры.


Нужно написать программу используя условие (If) на c++
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота