razumovnikita51
19.05.2021 15:32

Python множества

Напишите программу, которая удаляет из строки все повторяющиеся символы.
Входные данные
На вход программы подаётся строка, содержащая символы таблицы ASCII.
Выходные данные
Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gt78
12.08.2020 07:49

element_list = input().split()

for l in element_list:

   print(l, end = ' ') # до сортировки

for elem in element_list:

   if element_list.count(elem) != 1:

       for i in range(element_list.count(elem)):

           element_list.remove(elem)

for n in element_list:

   print(n, end = ' ') # после сортировки

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота