тата282
06.07.2022 17:11

Написать программу, которая определяет является ли введенное число х кратным 7.
Program Primer;
Var x: integer;
begin
writeln('Ввести x');
readln (x);
if x mod 7=0 then
writeln('Число делится на 7')
else
writeln('Число не делится на 7');
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenadub
30.04.2023 02:54

1)

39₁₀ = 47₈

127₁₀ = 177₈

512₁₀ = 1000₈

2)

67₈ = 55₁₀

354₈ = 236₁₀

42₈ = 34₁₀

Объяснение:

1)

16 / 8 = 2 + остаток 0

2 / 8 = 0 + остаток 2

записываем остатки снизу вверх

16₁₀ = 20₈

39 / 8 = 4 + остаток 7

4 / 8 = 0 + остаток 4

записываем остатки снизу вверх

39₁₀ = 47₈

127 / 8 = 15 + остаток 7

15 / 8 = 1 + остаток 7

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

127₁₀ = 177₈

512 / 8 = 64 + остаток 0

64 / 8 = 8 + остаток 0

8 / 8 = 1 + остаток 0

1 / 8 = 0 + остаток 1

записываем остатки снизу вверх

512₁₀ = 1000₈

2)

67₈ = 6 * 8¹ + 7 * 8⁰ = 6 * 8 + 7 * 1 = 48 + 7 = 55₁₀

354₈ = 3 * 8² + 5 * 8¹ + 4 * 8⁰ = 3 * 64 + 5 * 8 + 4 * 1 = 192 + 40 + 4 = 236₁₀

42₈ = 4 * 8¹ + 2 * 8⁰ = 4 * 8 + 2 * 1 = 32 + 2 = 34₁₀

0,0(0 оценок)
Ответ:
лёля558
30.04.2023 02:54

1)Если насыпать железную стружку на дощечку, под которой магнит, то стружка из перемешанного состояния структурируется в линии.
2)Например в герментичной ёмкости с двумя газами вскоре они переместятся и будет более неоднородная смесь. Также, например, при взрыве чего-либо сложная структура ломается. При ядерном взрыве тяжёлые сложные элементы распадаются на более мелкие.
3)Например из семечка вырастает дерево, а дерево имеет более сложную структуру, чем семечко. Аналогично с животными, например из яйца вылупляется цыплёнок. Также в ходе эволюции из одноклеточных организмов появились рыбы, у которых струтура намеого сложнее чем у одноклеточных организмов.
4)Получение: при глаз(зрение), носа(обояние), ушей(слух), вистибулярного опарата(положение в пространстве) и др. у млекопитающих и других относительно развитых организмов.
  У клеток при химических реакций.
  Передача:

 Многие млекопитающие издают звуки(кошки мяукают, птицы чирикают) оповещая своих сородичей, например, об обастности или о еде и др.
  Также через гены(мутации, эволюция).
  Использование: чтобы добывать пищу от опасности стае, заботится о детях, оринтироваться в пространстве.
5)Человек также, кроме того, что могут многие млекопитающие(слух, зрение и т.д.), может читать(зрение), определять север при компаса(зрение), сотреть на карту(зрение), слушать речь(в отличии от животных речь человека очень развита и передаёт в разы больше информации)(слух) и т.д..
6)Язык, на котором написано сообщение, должнен быть понятным для приёмника(русский, английский или какой-нибудь другой язык для человека, протокол общения для сервера)
7)Знания также должны быть понятны, но ещё посны и точны.
8)СМИ должны довать достоверную, понятную и полезную(актуальную) информацию.
9)Роботы, беспилотные летательные опараты(информация: о положении и курсе. команды: движения закрылок), марсоходы(информация: о приказе, изображение с камер и данные датчиков, команды: движения манипуляторов и колёс), система климат-контроля в машинах(информация: о температере, влажности и выбранном режиме работы, команды: включения/выключения нагреватель и открытия/закрытия воздухозаборников)
Микроволновка(информация: о режиме работы и оставшимся времени, команды: греть/негреть, крутить/некрутить и пикнуть)
10)на производстве роботы делают машины, паяют микросхемы, вытачивают мелкие детали. На марсе марсоходы иследуют марс.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота