Themrg
21.12.2020 00:20

РЕШИТЬ ЧЕРЕЗ С++

Написать программу, которая бы по введенному номеру единицы измерения (1 — дециметр, 2 — километр, 3 — метр, 4 — миллиметр, 5 — сантиметр) и длине отрезка L выдавала бы соответствующее значение длины отрезка в метрах.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Koopyosnik
12.10.2020 03:22

#include <iostream>

int main()

{

int n;

float l;

std::cin >> n >> l;

switch (n)

{

case 1:

 std::cout << "Length: " << l / 10;

 break;

case 2:

 std::cout << "Length: " << l * 1000;

 break;

case 3:

 std::cout << "Length: " << l;

 break;

case 4:

 std::cout << "Length: " << l / 1000;

 break;

case 5:

 std::cout << "Length: " << l / 100;

 break;

default:

 break;

}

std::cout << std::endl;

system("pause");

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота