nadyukov
28.02.2022 01:31

Задачи на языке программирования С++ (repl.it).

Задача 1. Задан массив действительных чисел размерности 10х10. Найти суммы элементов каждой строки, произведения элементов каждого столбца, и максимальный элемент главной диагонали (подсказка: все элементы, для которых номер строки совпадает с номером столбца).

Задача 2. Задан одномерный массив целых чисел. Образуйте из него два отсортированных по возрастанию массива, содержащих четные и нечетные числа.

Задача 3. Задан генератором случайных чисел одномерный массив из действительных чисел. Найдите максимальное и минимальное число этого массива.

Задача 4. Решето Эратосфена число – это любое целое число, которое точно делится без остатка только само на себя и 1. Решето Эратосфена работает следующим образом:

1) Создайте массив, все элементы которого имеют начальное значение 1 (истина). Элементы массива с индексами останутся равными 1. Все другие элементы массива, в конечном счете, установятся равными нулю.

2) Начиная с индекса массива 2 (индекс 1 должен быть каждый раз отыскивается элемент массива с единичным значением, циклически обрабатывается оставшаяся часть массива и устанавливается в нуль каждый элемент массива, чей индекс кратен индексу элемента с единичным значением. Для индекса 2 все элементы в массиве с большим чем 2 индексом и кратные 2 установятся равными нулю (индексы 4, 6, 8, …); для индекса 3 все элементы с индексом свыше 3 и кратные 3, установятся равными нулю (индексы 6, 9, 12, …) и т.д.

3) Когда процесс закончится, элементы массива с единичным значением указывают, что их индексы числа. Эти индексы могут быть напечатаны.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
FoxDi13
16.01.2021 14:30

Ақпараттық технологиялар саласы негізінен екі тәуелсіз циклде дамиды: өнімділік және қаржылық. Жақында біз қаржылық циклде екендігіміз туралы көптеген даулар болды; қаржылық нарықтарға көп көңіл бөлінеді, олар кейде өзін болжай алмайтындай ұстайды және қатты өзгеріп отырады. Екінші жағынан, өнімнің циклдеріне онша назар аударылмайды, дегенмен олар ақпараттық технологияны алға жетелейді. Бірақ өткен тәжірибені талдай отырып, сіз қазіргі өнім циклын түсінуге және технологиялардың болашақ дамуын болжауға тырыса аласыз. Жоғары технологиялар саласындағы өнім циклдарының дамуы платформалар мен қосымшалардың өзара әрекеттесуі арқылы жүреді: жаңа платформалар жаңа қосымшаларды құруға мүмкіндік береді, бұл өз кезегінде осы платформалардың құнын арттырады, осылайша оң кері байланыс циклін жабады. Шағын өнім циклдары үнемі қайталанып отырады, бірақ тарихи түрде 10-15 жылда бір рет тағы бір үлкен цикл басталатындай дамыды - бұл АТ-ны толық өзгертетін дәуір.

Объяснение:

0,0(0 оценок)
Ответ:
krasota33
02.01.2022 00:59
Дорога, соединяющая города i и j, даст единицу в две позиции - (i, j) и (j, i). Тогда общее количество единиц в матрице равно удвоенному числу дорог. Отсюда и простое решение - считать N^2 чисел, подсчитать количество единиц и поделить его на 2. Можно считать и сумму - от этого ничего не изменится.

   #include <iostream> 
   int main() {
       int n = 0, sum = 0, temp = 0;
       std :: cin >> n;
       for (int i = 0; i < n * n; i++) {
           std :: cin >> temp;
           sum += temp;
       }
       std :: cout << sum / 2;
       return 0;
   }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота