даданет
11.10.2021 02:26

Решить на Питоне
n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Входные данные Программа получает на вход числа n и k. Выходные данные Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Примечание: При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.

Примеры:

входные данные: 7, 30
выходные данные: 5

входные данные: 7, 28
выходные данные: 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kristibabiba098
17.08.2020 20:57

Объяснение:

Решить на питоне не могу, но могу дать тебе кусок кода и объяснить его.

int n,k,a;   //объявляешь переменные n,k,a

cin>>n>>k;  //считываешь с клавы

a = (n-k%n)%n;  //находишь a, где % это остаток от деления

cout<<a; //выводишь a

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота