hitman19102003
26.09.2021 17:06

Выберите правильный заполнения массива случайными числами:
а x[i]:=random(100);
б x[i]:=random[100];
в x[i]:=randam[100];
г x[i]:=randam(100);

2. Укажите правильную запись для присваивания элементу массива числа в диапазоне от – 100 до 100:
а. a[i]:=random(100-100);
б. a[i]:=random(201)-100;
в. a[i]:=random(100)-100;
г. a[i]:=random(200)-100;

3. Дан фрагмент программного кода, в котором используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 1; 4 1; 7; 10; 8; 7; 7; 8; 1 соответственно, т. е. A[1] = 1; A[2] = 4 и т. д. Чему равно значение Min_i?

Min:=A[1]; min_i:=1;
for i:=2 to 10 do
If A[i]<=Min then
Begin
Min:=A[i];
Min_i:=i;
End;
Writeln(Min_i);

4. Какой из приведенных методов является методом сортировки массива?
а. Метод наименьшего элемента.
б. Метод пузырька.
в. Метод наибольшего элемента.
г. Метод формирования нового массива.

5. Какое значение будет выведено на экран после выполнения программного кода?

const
M = 7;
N = 5;
var
a: array[1..N,1..M] of integer;
i, j, count: byte;
begin
randomize;
count := 0;
for i:=1 to N do begin
for j:=1 to M do begin
a[i,j] := random(1000);
write(a[i,j]:6);
if (a[i,j] > 9) and (a[i,j] < 100) then
count := count + 1
end;
writeln;
end;
writeln('count= ', count)
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lol1025
12.10.2020 10:20

1. а)

2. б)

3. 10.

4. б)

5. 2.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота