NShmak
16.02.2023 07:52

Составить программу нахождения суммы 5 целых чисел, используя функцию нахождения суммы двух целых чисел.
Язык ПАСКАЛЬ АБС

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nana08
16.03.2021 15:12

var

   d : array of integer;

   n : integer;

   

function arrSumRec(d : array of integer; n : integer) : integer;

begin

   if n > d.Length-1 then exit;

   result := d[n]+arrSumrec(d, n+1);

   n += 1;

end;


begin

   write('введите количество элементов для массива ');

   readln(n);

   d := new integer[n];

   d := arrRandom(n, 1, 100);

   writeln('сгенерирован массив из ', n, ' элементов со значениями в диапозоне 1..100');

   writeln(d);

   writeln('Сумма = ', arrSumRec(d, 0));

end.


функция function arrSumRec(d : array of integer; n : integer) : integer; в качестве первого параметра получает массив сумму которого считаем в качестве второго номер члена начиная с которого считаем сумму. Не забываем что нумерация начинается с нуля. поэтому чтобы посчитать сумму всех членов массива в качестве второго параметра указываем 0.

0,0(0 оценок)
Ответ:
rafael2003ggwp
16.03.2021 15:12

var

   d : array of integer;

   n : integer;

   

function arrSumRec(d : array of integer; n : integer) : integer;

begin

   if n > d.Length-1 then exit;

   result := d[n]+arrSumrec(d, n+1);

   n += 1;

end;


begin

   write('введите количество элементов для массива ');

   readln(n);

   d := new integer[n];

   d := arrRandom(n, 1, 100);

   writeln('сгенерирован массив из ', n, ' элементов со значениями в диапозоне 1..100');

   writeln(d);

   writeln('Сумма = ', arrSumRec(d, 0));

end.


функция function arrSumRec(d : array of integer; n : integer) : integer; в качестве первого параметра получает массив сумму которого считаем в качестве второго номер члена начиная с которого считаем сумму. Не забываем что нумерация начинается с нуля. поэтому чтобы посчитать сумму всех членов массива в качестве второго параметра указываем 0.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота