11Misha201
29.06.2022 03:51

ответьте, очень надо.

На вход программы поступают 4 неотрицательных целых числа, не превышающие 1000, среди которых могут быть одинаковые. Нужно написать программу, которая выводит количество чисел, кратных 3, и максимальное из этих чисел. Если среди входных данных нет чисел, кратных трёх, программы должна вывести слово 'NO'. Для решения этой задачи ученик написал такую программу:

const n = 4;

var i, x: integer;

var maximum, count: integer;

begin

count := 0;

maximum := 999;

for i:=1 to n do begin

read( x );

if x mod 3 = 0 then begin

count := count + 1;

if x < maximum then

maximum := x;

end;

end;

if count > 0 then begin

writeln(count);

writeln(maximum);

end

else

writeln('NO');

end.

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе чисел 2 9 4 3.

2. Приведите пример такой последовательности, содержащей число, кратное 3, что, несмотря на ошибки, программа выдаст верный ответ.

3. Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки: выпишите строку, в которой сделана ошибка, и приведите правильный вариант

строки.

Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
egorbelov06
10.07.2020 19:01
МОЖНО  ЗДЕЛАТЬ ТАК СКАЧАТЬ  ФОТО  С  ФРАНЦИИ НА  ПРЕЗЕНТАЦИ  И  НАПИСАТЬ  О  НЁМ РАСКАЗ  НАПРИМЕРФранция. Её воздух наполняет непередаваемым чувством свободы и ощущением влюбленности во весь мир. Французский язык, французская кухня, французская мода, французский образ жизни – так много причин, чтобы влюбиться в эту необыкновенную страну. Мало кто может искренне сказать, что не хотел бы побывать здесь хотя бы раз в жизни.Культурное наследие Франции не просто богато, очень богато. Франция подарила миру великих математиков, философов, писателей и художников. Винсент ван Гог и Пабло Пикассо, Декарт и Ларошфуко, Мольер и Александр Дюма, Оноре де Бальзак, Золя и Мопассан – это лишь неполный список выдающихся личностей, вырастивших свой талант на французской земле. Даже недолгое пребывание здесь выливается во что-то прекрасное. Во Франции нашли свое вдохновение и многие русские писатели и поэты: Иван Бунин, Александр Куприн, Марина Цветаева и Константин Бальмонт.Архитектура Франции по-настоящему красива и разнообразна. Памятники архитектуры времен античности, величественные готические сооружения, многочисленные замки в стиле эпохи Возрождения - Шамбор, Шенонсо, Шеверни, Блуа, Азэ-лё-Ридо и другие. Версаль, Люксембургский сад и Елисейские поля в Париже. И, конечно же, символ Франции - Эйфелева башня.:
0,0(0 оценок)
Ответ:
Vova50915091
26.02.2022 12:01
  program proga_25_1;
 Var
A: text;     
i,j,n,m : byte;     
 d: string;     
Sim:char;
 Begin             
write('Введите имя текстового файла   ');  {Например: "test" он создастся там где находится сама программа }               
read(d);                                       
 Assign(A,d);               
 rewrite(A);                   
 write('Введите количество строк: N= ');                        
readln(n);                   
 write('Введите количество символов в строке: M= ');                     
  readln(m);                                     
for I:=1 to n do                   
 begin                         
 Sim:=Chr(Ord('1')+I-1);                         
  For J:=1 to m do                             
  write(A,Sim);                               
 writeln(A);                 
  end;                         
  close(A);
end.     
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота