ulianaazet66
18.12.2021 21:07

Напишите программу на языке Паскаль, вычисляющую значение функции

5d, если d<5

A = 3d/(d+8), если d≥5

​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AAndrey7600
17.06.2022 15:48
Латинские буквы в кодовых таблицах КОИ-8 и Windows расположены в лексикографическом порядке и имеют одинаковые коды. Цифры и знаки препинания в кодовых таблицах КОИ-8 и Windows имеют различные коды. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в порядке возрастания их кодов. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в лексико-графическом порядке. Русские таблицы в кодовых таблицах КОИ-8 и Windows имеют различные коды. В кодовых таблицах КОИ-8 и Windows сначала расположены прописные русские буквы, а затем строчные. Русские прописные буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 223. Русские буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 225.

Модельный ответ:

Истинные высказывания: 3, 5, 8.

Модельный ответ с подсчетом баллов:

Каждый правильный ответ

Учащийся уложился в 5 минут (при правильном ответе)

Максимальный балл:

Задание №2. Информационная компетентность: Аспект "Первичная обработка информации". Уровень I.

Вам нреобходимо закодировать и раскодировать слова в десятичном и двоичном коде. Пользуясь кодовой таблицей ASCII,

а) закодируйте тексты:

 

 

Текст Десятичный код Двоичный код APPLE     DELETE     MOUSE     7-4=3    

 

б) декодируйте тексты:

Десятичный код Текст 69 78 84 69 82   80 65 73 78 84   66 65 67 75 83 80 65 67 69   Двоичный код Текст 01000101 01001110 01000100   01001000 01001111 01001101 01000101   01010111 01001111 01010010 01000100   01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100  

 

Модельный ответ:

а):

 

 

Текст Десятичный код Двоичный код APPLE 65 80 80 76 69 01000001 01010000 01010000 01001100 01000101 DELETE 68 69 76 69 84 69 01000100 01000101 01001100 01000101 01010100 01000101 MOUSE 77 79 85 83 69 01001101 01001111 01010101 01010011 01000101 7-4=3 55 45 52 61 51 00110111 00101100 00110100 00111110 00110011

 

б):

 

Десятичный код Текст 69 78 84 69 82 ENTER 80 65 73 78 84 PAINT 66 65 67 75 83 80 65 67 69 BACKSPACE Двоичный код Текст 01000101 01001110 01000100 END 01001000 01001111 01001101 01000101 HOME 01010111 01001111 01010010 01000100 WORD 01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100 FOOTBALL

 


0,0(0 оценок)
Ответ:
ника2569
12.01.2023 19:11
#include <iostream>
using namespace std;
struct P
{
    P() = default;
    P(int x, int y)
    {
        this->x = x;
        this->y = y;
    };

    int x;
    int y;
};

int main()
{
    int size;
    cin >> size;
    P *arr = new P[size];
    for (int i = 0; i < size; i++) {
        cin >> arr[i].x;
        cin >> arr[i].y;
    };

    P temp; // временная переменная для обмена элементов местами

              // Сортировка массива пузырьком
    for (int i = 0; i < size - 1; i++) {
        for (int j = 0; j < size - i - 1; j++) {
            if (arr[j].x > arr[j + 1].x) {
                // меняем элементы местами
                temp.x = arr[j].x;
                arr[j].x = arr[j + 1].x;
                arr[j + 1].x = temp.x;
            }
        }
    }

    // Вывод отсортированного массива на экран
    for (int i = 0; i < size; i++) {
        cout << arr[i].x << " ";
    }

    delete[] arr;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота