ariana201723
28.02.2023 22:47

Составьте программу вычисления в массиве А(10), заполненного случайными числами от 10 до 1000 , произведение однозначных чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
МиланаТрошина
19.04.2021 03:26

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

0,0(0 оценок)
Ответ:
trollotrollovit
04.11.2020 14:59

ответ:1) (1 б.) Верные ответы: 3;

2) (1 б.) Верные ответы: 4;

3) (1 б.) Верные ответы: 1; 2;

4) (1 б.) Верные ответы: 3;

5) (1 б.) Верные ответы: 1;

6) (1 б.) Верные ответы: 3;

7) (1 б.) Верные ответы: 4;

8) (1 б.) Верные ответы: 1;

9) (1 б.) Верные ответы: 3;

10) (1 б.) Верные ответы: 3;

11) (1 б.) Верные ответы: 2;

12) (1 б.) Верные ответы: 3;

13) (1 б.) Верные ответы: 4;

14) (1 б.) Верные ответы: 1;

15) (1 б.) Верные ответы: 1; 2;

16) (1 б.) Верные ответы: 1;

17) (1 б.) Верные ответы: 2;

18) (1 б.) Верные ответы: 1;

19) (1 б.) Верные ответы: 3;

20) (1 б.) Верные ответы: 2;

21) (1 б.) Верные ответы: 2;

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота