sergei19671
20.07.2021 13:01

нужно написать программу решения выражения в c++

11 вариант в закрепе

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PadhD
18.12.2022 16:26
//Dev-C++ 5.11

#include <stdio.h>
int binaryFounder(int*,int,int,int,int*);

int main(void)
 {int ar[100],n,res=-1,i,j,buf,val,arind[100];
 scanf("%d",&n);
 for(i=0;i<n;i++)
  scanf("%d",&ar[i]);
 printf("Enter searching value:");
 scanf("%d",&val);
 for(i=0;i<n;i++)
  arind[i]=i;
 for(i=0;i<n-1;i++)
  for(j=i+1;j<n;j++)
   if(ar[i]>ar[j])
    {buf=ar[i];
    ar[i]=ar[j];
    ar[j]=buf;
    buf=arind[i];
    arind[i]=arind[j];
    arind[j]=buf;}
 binaryFounder(ar,0,n-1,val,&res);
 if (res==-1)
  printf("Not found");
 else
  printf("Found in position %d",arind[res]);
 return 0;}

int binaryFounder(int ar[],int left,int right,int val,int* res)
 {int kar=(left+right)/2;
 if (*res!=-1)
  return 0;
 if (left>right)
  return 0;
 if (ar[kar]==val)
  *res=kar;
 if (ar[kar]<val)
  binaryFounder(ar,kar+1,right,val,res);
 if (ar[kar]>val)
  binaryFounder(ar,left,kar-1,val,res);}

Пример ввода:
5
1
2
3
4
5
4
Пример вывода:
Found in position 3 //считаем с 0
0,0(0 оценок)
Ответ:
llkk2003
24.03.2020 09:54

50 div 9 = 5

-10 mod (-5) = 0

round (9.5) = 10

trunc (15.6) = 15

Объяснение:

50 / 9 = 5 целых + 5 остаток

div - результат целочисленного деления

50 div 9 = 5

-10 / (-5) = 2 целых + 0 остаток

mod - остаток от целочисленного деления

-10 mod (-5) = 0

round - округленное до ближайшего целого, если вещественное число находится посередине между двумя целыми, то округление происходит к ближайшему чётному (round (2,5) = 2, round (3,5) = 4)

round (9.5) = 10

trunc - возвращает целую часть вещественного числа

trunc (15.6) = 15

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота