aliina000
01.08.2022 07:47

1. Откройте среду программирования Pascal.

2. Введите программу:

program dlina;

uses crt;

var s: string; t:integer;

begin

clrscr;

writeln (‘Введите произвольное слово’);

readln (s);

t:=length(s);

writeln (‘длина слова равна’,t);

readkey;

end.

3. Проверьте программу на наличие ошибок и запустите на выполнение.

Задание 2. Составить программу, определяющую истинность высказывания "Число n является четным"

program chetn;

uses crt;

var n: integer; a: boolean;

begin

clrscr;

write ('Введите исходное число');

readln (n);

a:=n mod 2=0;

writeln ('Число ', n,' является четным - ', a);

readkey;

end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
PRI3E
28.11.2022 07:26

1.       Основные этапы: подготовка материала для выбранной темы презентации.

·         Это изображения (простые и анимированные);

·         Тексты и цитаты из статей, книг, и других источников информации.

·         Видео и аудиозаписи, которые разнообразить и более наглядно раскрыть тему.

2.       Сценарий – это иными словами схема презентации.

·         Последовательность слайдов

·         Сопровождения материалов на слайде словами рассказывающего, чтобы более подробно раскрыть тему

На первом слайде обычно отображается тема, на последующих слайдах - цели, основной материал презентации. Заканчивается презентация слайдом с выводом и слайдом с благодарностью слушателям, за просмотренный материал и уделенное время.

3. После того, как набран материал для презентации и подготовлена схема – следует самому ещё просмотреть, чтобы исключить ошибки, которые могли возникнуть во время её составления (перепутались слайды, допущены ошибки в тексте, изображение на слайде перекрывает текст, плохо выбран цвет фона из-за чего не видно текст). Далее, если к презентации есть устное сопровождение – следует включить презентацию и сопровождать её устно, чтобы по времени определить примерное время всей презентации. Также это даст возможность настроить переключение слайдов по времени, когда вы будете знать, сколько должен определенный слайд держаться на экране, чтобы вы успели закончить устное сопровождение данного слайда.

4. Отличие в том, что в интерактивной презентации можно создать кнопки, при нажатии на которые может включиться воспроизведение видео или аудиозаписи, изменение изображения, чтобы наглядно показать разницу между предыдущим.

В целом, интерактивная презентация предполагает собой взаимодействие человека с презентацией, то есть какие-то изменения с разрешения человека во время её показа.

Презентация по сценарию же, идет последовательно и без вмешательства в её ход.

0,0(0 оценок)
Ответ:
daniiltkachuk1p02aol
28.11.2022 07:26
При кодировании первым для хранения номера одного инструмента требуется log(2)180 ≈ 8 бит.
Второй
X=2, количество инструментов в группе = 180/2 = 90
Объем памяти для кодирования = log(2)2+log(2)90 ≈ 1+7 = 8 бит.
X=3, количество инструментов в группе = 180/3 = 60
Объем памяти для кодирования = log(2)3+log(2)60 ≈ 2+6 = 8 бит.
X=4, количество инструментов в группе = 180/4 = 45
Объем памяти для кодирования = log(2)4+log(2)45 ≈ 2+6 = 8 бит.
X=5, количество инструментов в группе = 180/5 = 36
Объем памяти для кодирования = log(2)5+log(2)36 ≈ 3+6 = 9 бит.
ответ: X=5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота