Slvblgo
10.10.2020 02:56

ИКТ
Написать программу на Паскаль: Дан массив из 10 целых чисел, заполненный генератором случайных чисел [-15;19], отсортировать данный массив любым по возрастанию.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Qwerty1246
24.02.2023 08:55
Очень сильно зависит от контекста.
допустим, вы знали, что какая-то девочка должна была выйти, а вышла именно девочка в желтом. Тогда, так как могла выйти любая из 8-ми, а вышла именно в желтом, сообщение содержит 3 бита информации.
Если же выйти могло любое кол-во девочек, а вышла именно одна, да еще и с желтым платьем, то сообщение содержит 8 бит информации.
Теперь поясню: тут вопрос "какое кол-во информации" равнозначен вопросу "Сколько бит мне нужно, чтобы закодировать все комбинации".
Так, чтобы закодировать 8 цветов нужно всего 3 бита, чтобы закодировать группу девочек, нужно 8 бит (каждый бит соответствует девочке, бит is set означает, что она вышла, бит not set - что она не вышла)
0,0(0 оценок)
Ответ:
yanaiweey
24.02.2023 08:55
#include <stdio.h>

int main(void) {
    int Y[12];
    long int mult = 1;
    
    for (int i = 0; i < 12; i++) {
        printf("\nY[%d]=", i);
        scanf("%d", &Y[i]);
    }
    
    for (int i = 0; i < 12; i++) {
        mult *= Y[i];
    }
    
    printf("\n%f", pow(mult, 1.0/12));
    return 0;
}

Функция scanf() является процедурой ввода общего назначения, считывающей данные из пото­ка stdin. Она может считывать данные всех базовых типов и автоматически конвертировать их в нужный внутренний формат. Если бы printf() выполняла ввод, а не вывод, ее можно было бы назвать аналогом scanf().

Функция printf() записывает в stdout аргументы из списка arg-list под управлением строки, на которую указывает аргумент format.

Функция pow() возвращает значение base, возведенное в степень ехр, т. е. baseexp. Переполнение вызывает ошибку области значений. Также может возникнуть ошибка области определения.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота