mirst14
14.06.2020 08:09

1.ввести с клавиатуры массив из девяти элементов найти сумму всех элементов массива которые больше сорока пяти

2.ввести с клавиатуры массив из 9 элементов найти сумму всех элементов массива
3.написать программу поиска минимального нечетного элемента массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
emelik96
13.10.2020 06:23

1)

var a: array [1..9] of integer;

begin

   for var i := 1 to 9 do

   begin

       write('Введите ', i, ' элемент: ');

       readln(a[i]);

   end;

   var sum := 0;

   for var i := 1 to 9 do

       if a[i] > 45 then

           sum += a[i];

           

   writeln('Сумма: ', sum);

end.

2)

var a: array [1..9] of integer;

begin

   for var i := 1 to 9 do

   begin

       write('Введите ', i, ' элемент: ');

       readln(a[i]);

   end;

   var sum := 0;

   for var i := 1 to 9 do

           sum += a[i];

           

   writeln('Сумма: ', sum);

end.

3)

var a: array [1..9] of integer;

begin

   for var i := 1 to 9 do

   begin

       a[i] := random(-10, 10);

       write(a[i], ' ');

   end;

   writeln();

   var min := a[1];

   for var i := 2 to 9 do

       if (a[i] mod 2 <> 0) and (a[i] < min) then

           min := a[i];

           

   writeln('Min: ', min);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота