SoMood
03.07.2022 20:18

Напишите программу, которая принимает символьную строку, содержащую пароль пользователя. Программа должна сообщить является ли пароль надёжным. Критерии надёжности пароля:

1. Пароль должен содержать не менее 8 символов.

2. Пароль должен содержать заглавные и строчные буквы.

3. Пароль должен содержать цифры
Необходимо вывести строку «YES», если пароль надёжный, и строку «NO» в противном случае.

ВАЖНО!

Для решения задачи нужно использовать функции s.islower() и s.isupper()

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Miraflores18
15.12.2021 13:48

Объяснение:

program treugolnik;

uses crt;

var

x1, y1, x2, y2, x3, y3, p:real;

function dlina(a1,b1, a2,b2:real):real;

begin

dlina:=sqrt(sqr(a1-a2)+sqr(b1-b2));

end;

begin

writeln('Введите координаты 1-ой вершины');

write('x='); readln(x1);

write('y='); readln(y1);

writeln('Введите координаты 2-ой вершины');

write('x='); readln(x2);

write('y='); readln(y2);

writeln('Введите координаты 3-ей вершины');

write('x='); readln(x3);

write('y='); readln(y3);

p:=dlina(x1,y1,x2,y2)+dlina(x1,y1,x3,y3)+dlina(x2,y2,x3,y3);

writeln('Периметр=',p);

end.

0,0(0 оценок)
Ответ:
vxtrxxx
09.06.2022 07:10
Рабо́чий стол (англ. desktop) — в компьютерной терминологии основное окно графической среды пользователя вместе с элементами, добавляемыми в него этой средой.

Обычно на рабочем столе отображаются основные элементы управления графической средой и, опционально, какое-либо фоновое изображение.

В некоторых рабочих средах (например, в MS Windows или в рабочих средах, удовлетворяющих требованиям freedesktop.org — KDE, GNOME и т. п.) с рабочим столом ассоциируется определённый каталог в файловой структуре компьютера (при этом обычно можно перетащить файл из стандартного для данной среды файлового менеджера на рабочий стол, и он будет туда скопирован). Ассоциированный каталог обычно находится в личной папке пользователя.

Так как рабочий стол практически всегда виден (либо его можно увидеть, свернув открытые окна), его используют для хранения часто использующихся файлов, документов и ссылок/ярлыков на них. Определение рабочего стола иногда расширяют, включая в него панель задач.

С точки зрения оконной системы рабочий стол может не являться окном низшего уровня (в системах Windows это можно заметить, завершив процесс «explorer.exe»).

Название «Рабочий стол» (точнее, «крышка рабочего стола», «столешница» — калька с англ. desktop) происходит от сравнения окон со стопкой бумаг, лежащих на столе.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота