26dura
14.11.2021 11:21

Задача:

Размер файла V байт. Переведите в мегабайты и гигабайты.

program z4;

uses crt;

var b,m,g:real;

begin

readln(b);

m:=b/1024;

g:=m/1024;

writeln (m,' ',g);

end.

Задание:

Измените текст программы в соответствии с видеоуроком. А именно:

Вставьте перед командами readln(b) и writeln (m,' ',g) строки, которые будут пояснять смысл исходной и результирующих величин.

Отладьте программу в Паскале.

4.Используя материал видеоурока напишите программу для решения задачи:

Заработок папы a рублей в месяц, мамы – b рублей в месяц. В семье двое неработающих детей и дедушка. Пенсия дедушки c рублей. Какой средний доход в семье на одного человека?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dronton
26.02.2023 13:51
А еще можно без головной боли

// PascalABC.NET 3.0, сборка 1111
var
  a,b:BigInteger;
  sa,sb:string;
begin
  Write('Первое слагаемое: '); Readln(sa);
  if BigInteger.TryParse(sa,a)=False then Writeln('Это не целое число!')
  else begin
    Write('Второе слагаемое: '); Readln(sb);
    if BigInteger.TryParse(sb,b)=False then Writeln('Это не целое число!')
    else Writeln('Точный результат: ',a+b)
    end
end.

Тестовое решение:
Первое слагаемое: 5423323409523846095938445870434764308454095
Второе слагаемое: 7425543205430235436743455446541423534233
Точный результат: 5430748952729276331375189325881305731988328
0,0(0 оценок)
Ответ:
arsenii2309
26.02.2023 13:51
Var
  s,s1:string;
  a,b:array[1..100]of integer;
  i,n,x,k:integer;
    begin
      readln(s);
      readln(s1);
      n:=1;
       if length(s)>length(s1) then
        x:=length(s)
        else x:=length(s1);
         for i:=1 to length(s) do
         begin
          val(copy(s,i,1),k,n);
          a[i+x-length(s)]:=k;
         end;
           for i:=1 to length(s1) do
         begin
          val(copy(s1,i,1),k,n);
          b[i+x-length(s1)]:=k;
         end;
      for i:=1 to length(s) do
        a[i]:=a[i]+b[i];
        for i:=length(s) downto 2 do
        begin
         a[i-1]:=a[i-1]+a[i]div 10;
         a[i]:=a[i]mod 10;
        end;
      for i:=1 to length(s) do
       write(a[i]);
        
        
      end.
         
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота