Составьте программу Если цена товара С меньше 1000, то определим объем реализации М (количество проданного товара), иначе определить сумму выручки S и количество проданного товара N.
1) файл паскаля приложен. 2) код на c# static void Main(string[] args) { int a, b; a = Convert.ToInt32(Console.ReadLine()); b = Convert.ToInt32(Console.ReadLine()); if (a > 2) { Console.WriteLine(a / 2); Console.WriteLine(b - 1); } } 3) Код на vb dim a as integer = 0 dim b as integer = 0 a = cint(console.readline()) b = cint(console.readline()) if a > 2 then console.writeline( a / 2) console.writeline(b - 1) end if
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018 // Внимание! Если программа не работает, обновите версию!
begin var L:='бвгджзйлмнр'.ToList; var s:=ReadlnString; var p:=Pos('.',s); if p>0 then s:=s[:p]; var aw:=s.ToWords; var i:=1; while i<=aw.Length-1 do begin var L1:=L.ToList; foreach var c in L1 do if not aw[i-1].Contains(c) then L.Remove(c) else if aw[i].Contains(c) then L.Remove(c); i+=2 end; if L.Count>0 then L.Println(',') else Writeln('Нет звонких согласных, удовлетворяющих условию') end.