danilukm548p09te8
23.02.2023 20:30

1. Заполнить двумерный массив N x M случайными числами из интервала [-15; 15] и найти максимальный элемент лежащий на побочной диагонали.

2. Заполнить двумерный массив N x N случайными числами из интервала [-10; 10] и найти сумму минимального и максимального элемента.

Написать программу на языке Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
девочка25th
16.04.2020 17:49

p := sign(y + 13 * a) * power(abs(y + 13 * a), 1/3);

Объяснение:

Единственная проблема тут - как записать кубический корень. В паскале есть функция power(a, p), которая возводит a в степень p, но если p не целое, оно работает только для положительных (для p > 0 неотрицательных) a. Кубический корень же определён для всех a.

Решение такое: посчитать кубический корень для модуля \sqrt[3]{|a|}=|a|^{1/3}, а потом поставить такой же знак, что и под корнем.

Полностью программа может выглядеть, например, так:

var p, y, a: real;

begin

 read(y, a);

 p := sign(y + 13 * a) * power(abs(y + 13 * a), 1/3);

 write(p)

end.

0,0(0 оценок)
Ответ:
Nelia88
10.12.2021 18:44

Саша - вышивание, Маша - танцы, Валя - рисование.

Объяснение:

Либо часть про Сашу, либо про Машу ложна (два верных утверждения быть не может). Тогда либо Саша занимается вышиванием, либо Маша - рисованием.

1) Саша занимается вышиванием. Тогда Валя не может заниматься вышиванием, её часть гарантированно ложна. Значит, верно утверждение про Машу: она не занимается рисованием, ей остаются танцы. Получается, Валя занимается рисованием.

2) Маша занимается рисованием. Остается два высказывания: Саша не занимается вышиванием, Валя - занимается вышиванием. Одно из этих утверждений истинно, другое ложно. Но если истинно первое, то обе девочки не занимаются вышиванием, если истинно второе - обе занимаются. Такого быть не может, поэтому Маша не может заниматься рисованием.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота