Chvrv
14.11.2020 21:42

ПО ИНФОРМАТИКЕ ОТ

1. Заполнить двумерный массив N x N случайными числами из интервала [-10; 10] и заменить максимальный элемент на противоположный по знаку.
2. Заполнить двумерный массив N x N случайными числами из интервала [-10; 10], найти минимальный элемент и увеличить его в два раза.
Написать программу на языке Паскаль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ayvazyanloxq37n
13.10.2020 09:55

program gulkakh;

const n=5;

var a:array[1..n,1..n] of integer;   

i,j,k,max,stroka:integer;

begin

writeln('Исходная матрица:');

for i:=1 to n do   

for j:=1 to n do    begin   

 a[i,j]:=random(20)-10;   

 write(a[i,j],' ');   

  if j=n then writeln; 

  end;   

 stroka:=1;

max:=a[1,1];

for i:=1 to n do

for j:=1 to n do begin

if max<a[i,j] then begin

max:=a[i,j];

stroka:=i;

end;

end;

k:=n;

for i:=stroka to n-1 do

for j:=1 to n do

a[i,j]:=a[i+1,j];

k:=k-1;

writeln('Без удаленной строки:');

for i:=1 to k do 

 for j:=1 to n do begin

  write(a[i,j],' '); 

if j=n then writeln; 

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота